job.answiz.com
  • 1
Votes
name

All I wanted to do today was to write a redirect rule to a subfolder, e.g.: You enter the URL: example.com and you get redirected to example.com/subfolder

Such a simple wish. I tried to find a solution on the internet. The internet told me to add an .htaccess file in the htdocs root with:

RewriteEngine on
RewriteCond %{HTTP_HOST} ^example.com$
RewriteRule (.*) http://www.example.com/$1 [R=301,L]
RewriteRule ^$ subfolder [L]

I did this. But no success obviously, they didn't told me I had to uncomment the module in httpd.conf:

LoadModule rewrite_module modules/mod_rewrite.so

So I did this too. No success again. They didn't told me I had to change my httpd.conf so that the .htaccess file would be enabled:

<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
</Directory>

DocumentRoot "c:/Apache24/htdocs"
<Directory "c:/Apache24/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

Again no success, because I get this error when entering the URL:

Forbidden You don't have permission to access / on this server.

Now I'm stuck and I couldn't find any more solutions on the internet. I'm just running Apache 2.4 on my Windows 7 machine, for private reasons.

 

The problem was because i was hasty and forgot to properly configure httpd-vhosts and instead of:

<Directory "e:/wamp64/www/"> Options +Indexes +FollowSymLinks +MultiViews AllowOverride All require all granted </Directory>

I had:

<Directory "e:/wamp64/www/"> Options +Indexes +FollowSymLinks +MultiViews AllowOverride All require local </Directory>

  • 0
Reply Report