• 1

I just updated to Mac OS 10.11 Sierra lately and classic web server is not working properly, or I should say that my home directory is not working Apache server is working at localhost as I get the 'It works' page, but localhost/~myuser is giving this message 'The requested URL /~myuser was not found on this server' I tried to follow this tuto but it is still not working

Can someone help me?


What worked for me after upgrading from El Capitan to Sierra as well:

1) Uncommenting from /etc/apache2/httpd.conf

LoadModule userdir_module libexec/apache2/
LoadModule vhost_alias_module libexec/apache2/
Include /private/etc/apache2/extra/httpd-vhosts.conf
Include /private/etc/apache2/extra/httpd-userdir.conf

2) Uncomment from /etc/apache2/extra/httpd-userdir.conf

Include /private/etc/apache2/users/*.conf

3) In my /etc/apache2/users/$USERNAME.conf file I had ProxyPass configured as well, and to get it working again I had to re-uncomment the following from my httpd.conf

LoadModule proxy_module libexec/apache2/
LoadModule proxy_http_module libexec/apache2/

4) Optional for PHP: You need to re-uncomment the following from the httpd.conf as well:

LoadModule php5_module libexec/apache2/

5) Of course, restart apache

sudo apachectl -k restart

Things worked for me afterwards, however I am better motivated now to start moving to Vagrant.

  • 0
Reply Report