• 3
Votes
name
name Punditsdkoslkdosdkoskdo

MacBook Air constanty drops wireless association.

My MacBook Air keeps dropping wifi connection on my home network. When I connect to my network, it remains connected for a few minutes, then it drops the connection. I have no idea what's the problem. I found several forums on the internet discussing this, but none of them really gave a working solution. My MacBook is 13" 2012 base model (MacBookAir5,2), I'm running the latest developer version of OS X Yosemite as of October 14th 2014 (GM 3.0 I believe), and my router is a TP-Link TL-WR741ND. These are the things that I found on the internet, and I tried all of them:

  • Upgrading the router to latest firmware, resetting it
  • Changing the WPA2-PSK mode to AES
  • Set a different channel on the router
  • Deleting the network information as well as related keychain items, repair permissions in Disk Utility, restart, reenter password for network
  • Simply turning off/on the wifi on my computer
  • I set the permissions of the Keychain items for my network so that every app can access it
  • Swap the router for a different one (exact same kind, I have two of them)

All this with no luck. My MacBook still drops wifi every couple of minutes. I have been using the same router for months now, and I never had a single problem with it. This only started recently. I wonder if it's something in the latest version of Yosemite? I have been regularly updating to the latest version of it since the first developer beta came out this summer.

So what else can I do? It's very frustrating. This is the only network that my MacBook can't handle, and this is also the only device on the network that does this. Every other network is fine on my MacBook, and every other device on this network is fine as well.

 

The WiFi on my iMac kept disconnecting each time the computer went to sleep, about 15 min when computer was not used. I solved it by going to energy saver in system preferences to extend the computer sleep time and unselected the "put the hard disk/s to sleep when possible" The display sleep time doesn't matter, it's the hard drives that should stay awake much longer. It worked for me.

  • 0
Reply Report

I did some more research, and came up with a temporary solution. Not the best thing to do, but it certainly worked for me. So whoever has the same problem, do this:

  • open Automator, select Application
  • add a Shell Script item
  • enter the following command in it: ping -i 0.2 192.168.1.1 (or whatever the IP of your router is)

Just save the app, start it and let it run. This will prevent your mac from dropping the connection.

The problem is that OS X tries to put the WiFi antenna into a power saving mode if there's no data being sent or received, but with some WiFi APs, this leads to disconnecting. That ping command will ping your router every 0.2 seconds, preventing OS X from turning off the WiFi.

This is not a brilliant solution, but it will work until Apple does something about this.

  • 0
Reply Report