job.answiz.com
  • 4
Votes
name
name Punditsdkoslkdosdkoskdo

Macbook Pro Ubuntu introduce freezes after grub menu

I am trying to install Ubuntu 14.10 (also tried 14.04.1 LTS) on my 2009 Macbook Pro 5,2. I have installed rEFInd, I have made a bootable USB as instructed on the Ubuntu site. I can get to the grub screen. But when I select to either try Ubuntu or install it, I get an error saying i8042: No Controller Found and the process freezes. I have to turn off the machine using the power button.

I have googled around and it seems that it might be related to the keyboard or trackpad, maybe?

I have tried using nomodeset boot option from rEFInd and the grub boot command editor, but I still get the same result. I also tried using these boot options: i8042.nopnp noacpi nolapic atkbd.reset. Same result.

For what its worth, I have replaced my optical drive with a second hard drive, which is the intended destination for the install. Any help getting started would be greatly appreciated!

Thanks!

edit: Also, my primary hard drive is an SSD and is running OS X Mavericks with disk encryption. Note that I am not trying to install Ubuntu on this disk but on a second internal HDD. Not sure if the disk encryption matters though.

Update: I have made some progress. By editing the boot options in the grub loader, I have new information. I removed the quiet and splash parameters and added acpi=off. The process is much more verbose now. Also, it ends up dropping into the Busy Box terminal with a flashing cursor. But I can not type anything, the keyboard is not responsive at all.

Any help at all would be greatly appreciated!

For anyone else having this problem, it seems like it might be caused by a display driver issue. This can be fixed by adding the 'nomodeset' parameter in the kernel settings on startup. This instructs the kernel to not load video settings during startup but leave it to the X driver when it loads. This means no beautiful splash screen on startup but it beats a non-functional kernel.

The following link might be useful for people who don't know how to add the parameter: http://ubuntuforums.org/showthread.php?t=1613132

PS This issue might also be fixable by correcting video driver settings once the system is booted up. However, this still requires the above step for an initial boot.

  • 0
Reply Report

I managed to solve my problem by turning off disk encryption on the Mac OS X SSD. The solution was less than ideal, but I now have two hard drives in my Macbook Pro, an SSD with OS X Mavericks and an HDD with Ubuntu.

  • 0
Reply Report