job.answiz.com
  • 4
Votes
name

I have a problem which I've faced for about 3 years and it's driving me crazy!

My Wi-Fi is connected and has very good signal but after a few minutes (sometimes few hours, hard to say) I have no internet. YouTube starts spinning, any open sites just stop reacting, everything is offline even though Wi-Fi is still connected.

To fix it, I "turn off Wi-Fi" and turn it on again. And I repeat this 50 times per day.

enter image description here

I'm not even sure if this is a problem with the MacBook.

I currently have a 2017 MBP 13", basic model. I also have another 2017 MBP 13, 2015 MBP 15" and 2015 MBP 13".

I also have a PC which is connected via USB external Wi-Fi card (some cheap TPLINK) and I don't think it's that bad. It's also 2.4ghz

I have a few routers with included AP from my provider, I recently changed to Unify Lite and nothing helped. I have 2 separated Wi-Fi, 2.4ghz and 5hz (currently 40mhz band and I've tried different configs).

What I've noticed:

  • when I go to another room, also closer to the AP, it's stable
  • When I turn off Bluetooth, it seems to be better - but I don't get it since 5GHZ shouldn't conflict with 2.4GHZ Bluetooth. I have speakers, magic mouse and magic keyboard connected (v2)
  • In my office, I see this problem but not that often - also MM and MK connected via Bluetooth
  • My girl's MBP2015 15" and MBP2017 15" don't cause problems but she works from a different room.
  • Occasionally I do these tips with cleaning PRAM etc and it seems to work for few hours, but later it's the same.

Anyway, I know that the answer could be:

  • don't use Bluetooth anymore lol
  • change your room lol

I'm actually being driven crazy and I want to know WHY I have this problem so I can solve it.

What diagnostics should I run?

I think you guys are on the wrong track here. Lets simply the issue first then see if something deeper is involved.

Click on the WiFi Menu Icon, Open Network Preferences entry. Hi-lite the WiFi entry and it needs to be the top entry (drag it their if need be). Click on the Advanced Button which will open up your WiFi AP's your system has connected to. Remove all of the unused networks and place the one you are using to the top. Save the settings and restart your system it should now be connected to this network. Put your system to sleep and wake it give it a moment if you had let it sit more than a few hours it should then automatically hook back up.

Did that fix things?

Update (02/17/2018)

Well I was hoping we didn't need to replace the Airport board and may need to replace the cable as well. Here's the IFIXIT guide you'll need to follow: MacBook Pro 13" Unibody Mid 2009 AirPort Card Replacement and heres the two parts you'll need:

If the cable needs replacing you'll need to pop off the to get the iSight camera as the cable also services it. Here's the IFIXIT guide you'll need to follow: MacBook Pro 13" Unibody Mid 2009 Front Display Glass Replacement

One Last Thing

While I haven't done it, the 2010 AirPort Extreme board should also work in your system: AirPort Card Extreme - Apple P/N 661-5593. It will get you better WiFi connections.

  • 1
Reply Report

What does Wireless Diagnostics show?

Wireless Diagnostics

Wi-FI connection drops

Wi-Fi Problems in OS X Yosemite

Wi-Fi Problems in OS X Yosemite (2)

Wi-Fi Problems in OS X Yosemite (3)

WiFi Potential Temporary fix - Yosemite

Also try turning off Bluetooth.

WIFI AND BLUETOOTH FINALLY SOLVED, NO REALLY - YOSEMITE 10.10

If your Wi-Fi source is capable of generating a 5 GHz Wi-Fi network, try that to help avoid conflicts with Bluetooth.

  • 1
Reply Report

Looking at your WiFi report, I would say it is not very good overall.

When RSSI reaches 72 the OSX WiFi will try to switch to next best (on your WiFI list).

Yours is at 70 which is not good at all.

Your Tx Rate is also very low (Slow)

Resulting MCS index is to low (2)

Here is an example of excellent WiFi.

enter image description here

Clean (remove) WiFi stations on your list.

Reorder the order of WiFi AP's on your list (drag up or down)

Further improvement to the RSSI can be achieved by switching the Chanel (to avoid overcrowding from other WiFi on same channel.)

You can run this in Terminal that will show last 24 hours of why the WiFi was disconnected.

log show --predicate '(processImagePath contains "kernel") && (eventMessage contains "AirPort: Link Down")' --style syslog --last 1d

Important to know. The AirPort will keep the WiFi information on for some time (making you believe it is connected) before correcting that.

  • 4
Reply Report