job.answiz.com
  • 3
Votes
name
name Punditsdkoslkdosdkoskdo

Make Windows 7 ignores WiFi when ethernet is availables

When I dock my Windows 7 laptop, I want it to prefer the wired ethernet connection over WiFi.

This is a pretty straightforward thing to do on my Mac - I just reorder my network preferences, and it "does the right thing." I just can't figure out how to achieve the same thing on my Win7 laptop.

So, when I'm docked, it connects to WiFi, and then fails to connect to servers on the local wired network. How do I fix this?

Go to Control Panel -> Network and Sharing Center -> Change adapter settings -> Then 'Right Click' on the Wireless network and select Status Then click Wireless Properties and make sure that if you have it set to connect when in range that it is also set to connect to Connect to a more preferred network if available.

  • 3
Reply Report

It's on Windows 7, but it's pretty well hidden.

Go to Control Panel -> Network and Sharing Center -> Change adapter settings -> The hit Alt to get the menu and choose Advanced -> Advanced Settings.

Then you can re-order your connections in that list.

Although Windows should already automatically prefer your wired over your wireless connection. It chooses what adapter to use based on the lowest interface metric, and a wirelesss connection should have a higher metric than your wired. Run route print from the command prompt to see that.

  • 3
Reply Report