job.answiz.com
  • 4
Votes
name
name Punditsdkoslkdosdkoskdo

how much take to logout Apache2 Proxy timeout

I have Apache2 with PHP + PHP-FPM configured according to:

http://wiki.apache.org/httpd/PHP-FPM

I am writing a script that will take a long time to execute on an internal Vhost, but keep getting timed out, everything runs flawlessly if the script executes in under 30 seconds.

My apache log tells me:

[Wed Apr 17 21:57:23.075175 2013] [proxy_fcgi:error] [pid 9263:tid 140530454267648] (70007)The timeout specified has expired: [client 58.169.202.172:49017] AH01075: Error dispatching request to :, referer:

When trying to run the script I am given a 503 Service Unavailable after exactly 30 seconds of execution time. Logically this would mean I have a timeout directive or setting set to 30 seconds, but I have these in my Vhost's config:

Timeout 600
<IfModule proxy_module>
    ProxyPassMatch ^/(.*.php)$ fcgi://127.0.0.1:9001/home/pyrokinetiq/scripts/$1 timeout=600
    ProxyTimeout 600
</IfModule>

(php-fpm is running on port 9001 for me)

I have also tried placing the Timeout and ProxyTimeout in httpd.conf with no difference.

It seems there's another timeout setting somewhere that's specific to mod_proxy_fcgi, but I can't find it. I installed the Apache2 httpd from the official tarball, none of the mods seem to have come with any configuration files.

If anyone can point me in the right direction it would be much appreciated.

Since you've fixed the timout settings in apache, that shouldn't be the issue. The second place to look would be any network equipment, but since you're proxying to your own server, that's also unlikely. So the remaining place to look is at the backend server.

Ih the config file for php-pfm, look for

; This is a hard kill switch on php execution.  It ignores the
; max_execution_time that can be set/changed with php_ini.  Basically
; it avoids timeout issues between apache and php-fpm.
request_terminate_timeout=30

This should be set to the same as, or slightly below, the timeout setting in apache.

  • 0
Reply Report

I have Apache 2.4.6, but the patch to fix it is provided in Apache >= 2.4.8. The key here is to startyour output immediately so that Apache (mod_proxy_fcgi) thinks the connection is active.

For example, I am using PHP and the DB query for my AJAX call takes > 30 seconds. Because I know that the overall response will be "Content-Type: application/json", I send that header immediately.

#1: Start output immediately
#Note: Sending the header is innocuous
#   it can be changed later using the $replace parameter
#   (see #3)
header( 'Content-Type: application/json' );

#2: Run slow query
mysql_query( "SELECT * FROM giant_table" );

#3: Change header as needed
header( 'Content-Type: application/csv', true );

#output content
  • 0
Reply Report

I finally fixed this problem after testing several configuration parameters. I tested the solution twice, removing all previous changes. Only one parameter was needed for me to fix it.

For the latest versions of httpd and mod_proxy_fcgi you can simply add timeout= to the end of the ProxyPassMatch line, e.g.:

ProxyPassMatch ^/(.+.php.*)$ fcgi://127.0.0.1:9000/<docroot>/$1 timeout=1800

For older versions it was a little more complicated, e.g.:

<Proxy fcgi://127.0.0.1:9000>
  ProxySet timeout=1800
</Proxy>
ProxyPassMatch ^/(.+.php.*)$ fcgi://127.0.0.1:9000/<docroot>/$1

I needed to add the Proxy directive to set the timeout to 30 minutes. In some applications, usually when operating database, there are routines that can take more than 10 minutes to execute. I temporary set the timeout to 30 minutes to ensure they finish. Specifically useful when using the installation wizard, which takes too much time (in my humble opinion).

By the way the intial input that helped me to solve this issue was found in the following URL address

  • 0
Reply Report